summaryrefslogtreecommitdiffstats
path: root/kaddressbook/interfaces/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-12 16:15:10 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-12 16:15:10 +0200
commit0d3043b6308af148da06ac14c53defc4b1e7e138 (patch)
tree2e9364cb143e70ee062e443275b852b8e2061888 /kaddressbook/interfaces/CMakeLists.txt
parent7c7363c3ca7fb9633d93cefde3cd54b144eee633 (diff)
downloadtdepim-0d3043b6308af148da06ac14c53defc4b1e7e138.tar.gz
tdepim-0d3043b6308af148da06ac14c53defc4b1e7e138.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kaddressbook/interfaces/CMakeLists.txt')
-rw-r--r--kaddressbook/interfaces/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/kaddressbook/interfaces/CMakeLists.txt b/kaddressbook/interfaces/CMakeLists.txt
index b0511b83..97a634ee 100644
--- a/kaddressbook/interfaces/CMakeLists.txt
+++ b/kaddressbook/interfaces/CMakeLists.txt
@@ -33,10 +33,13 @@ install( FILES
##### other data ################################
-install( FILES
+tde_create_translated_desktop(
+ SOURCE
kaddressbook_contacteditorwidget.desktop
kaddressbook_extension.desktop kaddressbook_xxport.desktop
- DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR kaddressbook-desktops
+)
##### kabinterfaces (shared) ####################