summaryrefslogtreecommitdiffstats
path: root/kmail/profiles/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-12 16:15:10 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-12 16:15:10 +0200
commit0d3043b6308af148da06ac14c53defc4b1e7e138 (patch)
tree2e9364cb143e70ee062e443275b852b8e2061888 /kmail/profiles/CMakeLists.txt
parent7c7363c3ca7fb9633d93cefde3cd54b144eee633 (diff)
downloadtdepim-0d3043b6308af148da06ac14c53defc4b1e7e138.tar.gz
tdepim-0d3043b6308af148da06ac14c53defc4b1e7e138.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kmail/profiles/CMakeLists.txt')
-rw-r--r--kmail/profiles/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/kmail/profiles/CMakeLists.txt b/kmail/profiles/CMakeLists.txt
index 2d2367b0..964195f6 100644
--- a/kmail/profiles/CMakeLists.txt
+++ b/kmail/profiles/CMakeLists.txt
@@ -12,7 +12,10 @@
set( profiles default html high-contrast purist secure )
foreach( profile ${profiles} )
- install( FILES "profile-${profile}-rc.desktop"
+ tde_create_translated_desktop(
+ SOURCE "profile-${profile}-rc.desktop"
DESTINATION ${DATA_INSTALL_DIR}/kmail
- RENAME profile-${profile}-rc )
+ OUTPUT_NAME profile-${profile}-rc
+ PO_DIR kmail-desktops
+ )
endforeach( )