summaryrefslogtreecommitdiffstats
path: root/korganizer/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-12 16:15:10 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-12 16:15:10 +0200
commit0d3043b6308af148da06ac14c53defc4b1e7e138 (patch)
tree2e9364cb143e70ee062e443275b852b8e2061888 /korganizer/CMakeLists.txt
parent7c7363c3ca7fb9633d93cefde3cd54b144eee633 (diff)
downloadtdepim-0d3043b6308af148da06ac14c53defc4b1e7e138.tar.gz
tdepim-0d3043b6308af148da06ac14c53defc4b1e7e138.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'korganizer/CMakeLists.txt')
-rw-r--r--korganizer/CMakeLists.txt22
1 files changed, 14 insertions, 8 deletions
diff --git a/korganizer/CMakeLists.txt b/korganizer/CMakeLists.txt
index a5e8aff1..00bc3577 100644
--- a/korganizer/CMakeLists.txt
+++ b/korganizer/CMakeLists.txt
@@ -53,21 +53,27 @@ link_directories(
tde_install_icons( )
-install( FILES
- korganizer.desktop
- DESTINATION ${XDG_APPS_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE korganizer.desktop
+ PO_DIR korganizer-desktops
+)
-install( FILES
- dcopcalendar.desktop
- DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE dcopcalendar.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR korganizer-desktops
+)
-install( FILES
+tde_create_translated_desktop(
+ SOURCE
korganizer_configmain.desktop korganizer_configtime.desktop
korganizer_configviews.desktop korganizer_configcolors.desktop
korganizer_configfonts.desktop korganizer_configplugins.desktop
korganizer_configgroupscheduling.desktop korganizer_configfreebusy.desktop
korganizer_configdesignerfields.desktop webcal.protocol
- DESTINATION ${SERVICES_INSTALL_DIR} )
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR korganizer-desktops
+)
install( FILES
uninstall.desktop