summaryrefslogtreecommitdiffstats
path: root/tdefile-plugins/diff/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:05:39 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:05:39 -0600
commitff94d46e423398804d2ae63faeb114c2cf604fc4 (patch)
tree4481ffd491d15ac15081cea46d7cc298ef6351a4 /tdefile-plugins/diff/Makefile.am
parentb9553cef2a3cd9f5b89c8aca6f4b7781a079dbb7 (diff)
downloadtdesdk-ff94d46e423398804d2ae63faeb114c2cf604fc4.tar.gz
tdesdk-ff94d46e423398804d2ae63faeb114c2cf604fc4.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdefile-plugins/diff/Makefile.am')
-rw-r--r--tdefile-plugins/diff/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/tdefile-plugins/diff/Makefile.am b/tdefile-plugins/diff/Makefile.am
new file mode 100644
index 00000000..5e9b087f
--- /dev/null
+++ b/tdefile-plugins/diff/Makefile.am
@@ -0,0 +1,22 @@
+## Makefile.am for diff file meta info plugin
+
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = tdefile_diff.h
+
+kde_module_LTLIBRARIES = tdefile_diff.la
+
+tdefile_diff_la_SOURCES = tdefile_diff.cpp
+tdefile_diff_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+tdefile_diff_la_LIBADD = $(LIB_KSYCOCA)
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages:
+ $(XGETTEXT) *.cpp *.h -o $(podir)/tdefile_diff.pot
+
+services_DATA = tdefile_diff.desktop
+servicesdir = $(kde_servicesdir)