summaryrefslogtreecommitdiffstats
path: root/tdefile-plugins/ts/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-16 18:30:12 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-17 02:50:29 +0200
commit7fa2dd79a4f7711a65b45724448c1529dfb94e9f (patch)
tree0192394f73f297cd56aa972df31bf8bfc07a71d3 /tdefile-plugins/ts/CMakeLists.txt
parent29e1ae5e34974950ff7965b1522db70b4ff273dc (diff)
downloadtdesdk-7fa2dd79a4f7711a65b45724448c1529dfb94e9f.tar.gz
tdesdk-7fa2dd79a4f7711a65b45724448c1529dfb94e9f.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'tdefile-plugins/ts/CMakeLists.txt')
-rw-r--r--tdefile-plugins/ts/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/tdefile-plugins/ts/CMakeLists.txt b/tdefile-plugins/ts/CMakeLists.txt
index ff95bff9..4308bb46 100644
--- a/tdefile-plugins/ts/CMakeLists.txt
+++ b/tdefile-plugins/ts/CMakeLists.txt
@@ -22,8 +22,11 @@ link_directories(
##### other data ################################
-install( FILES tdefile_ts.desktop
- DESTINATION ${SERVICES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE tdefile_ts.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR tdefile-desktops
+)
##### tdefile_ts (module) #########################