summaryrefslogtreecommitdiffstats
path: root/umbrello/umbrello/codegenerators/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitbd9e6617827818fd043452c08c606f07b78014a0 (patch)
tree425bb4c3168f9c02f10150f235d2cb998dcc6108 /umbrello/umbrello/codegenerators/Makefile.am
downloadtdesdk-bd9e6617827818fd043452c08c606f07b78014a0.tar.gz
tdesdk-bd9e6617827818fd043452c08c606f07b78014a0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdesdk@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'umbrello/umbrello/codegenerators/Makefile.am')
-rw-r--r--umbrello/umbrello/codegenerators/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/umbrello/umbrello/codegenerators/Makefile.am b/umbrello/umbrello/codegenerators/Makefile.am
new file mode 100644
index 00000000..bc622fe0
--- /dev/null
+++ b/umbrello/umbrello/codegenerators/Makefile.am
@@ -0,0 +1,38 @@
+noinst_LTLIBRARIES = libcodegenerator.la
+
+INCLUDES = -I../dialogs -I$(top_srcdir)/umbrello/umbrello/dialogs $(all_includes)
+
+libcodegenerator_la_LDFLAGS = $(all_libraries)
+libcodegenerator_la_METASOURCES = AUTO
+libcodegenerator_la_SOURCES = codegenfactory.cpp classifierinfo.cpp \
+ javacodegenerator.cpp javaantcodedocument.cpp javacodeclassfield.cpp \
+ javaclassifiercodedocument.cpp javacodecomment.cpp javacodedocumentation.cpp \
+ javacodeoperation.cpp javacodeaccessormethod.cpp \
+ javaclassdeclarationblock.cpp javacodeclassfielddeclarationblock.cpp \
+ javacodegenerationpolicy.cpp javacodegenerationpolicypage.cpp \
+ javacodegenerationformbase.ui \
+ cppcodegenerator.cpp cppcodedocumentation.cpp cppcodeclassfield.cpp \
+ cppcodecomment.cpp cppmakecodedocument.cpp \
+ cppsourcecodedocument.cpp cppsourcecodeoperation.cpp cppsourcecodeaccessormethod.cpp \
+ cppsourcecodeclassfielddeclarationblock.cpp \
+ cppheadercodedocument.cpp cppheaderclassdeclarationblock.cpp \
+ cppheadercodeoperation.cpp cppheadercodeaccessormethod.cpp \
+ cppheadercodeclassfielddeclarationblock.cpp \
+ cppcodegenerationpolicy.cpp cppcodegenerationpolicypage.cpp \
+ cppcodegenerationformbase.ui cppcodegenerationform.cpp \
+ rubycodegenerator.cpp rubycodeclassfield.cpp \
+ rubyclassifiercodedocument.cpp rubycodecomment.cpp rubycodedocumentation.cpp \
+ rubycodeoperation.cpp rubycodeaccessormethod.cpp \
+ rubyclassdeclarationblock.cpp rubycodeclassfielddeclarationblock.cpp \
+ rubycodegenerationpolicy.cpp rubycodegenerationpolicypage.cpp \
+ rubycodegenerationformbase.ui \
+ simplecodegenerator.cpp \
+ adawriter.cpp aswriter.cpp cppwriter.cpp csharpwriter.cpp dwriter.cpp javawriter.cpp jswriter.cpp \
+ idlwriter.cpp pascalwriter.cpp perlwriter.cpp php5writer.cpp phpwriter.cpp \
+ pythonwriter.cpp rubywriter.cpp sqlwriter.cpp tclwriter.cpp xmlschemawriter.cpp \
+ xmlelementcodeblock.cpp xmlcodecomment.cpp \
+ codegen_utils.cpp
+libcodegenerator_la_COMPILE_FIRST = ../dialogs/codegenerationpolicybase.h
+
+KDE_OPTIONS = nofinal
+