summaryrefslogtreecommitdiffstats
path: root/kodo/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kodo/Makefile.am')
-rw-r--r--kodo/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/kodo/Makefile.am b/kodo/Makefile.am
new file mode 100644
index 0000000..38bfbd5
--- /dev/null
+++ b/kodo/Makefile.am
@@ -0,0 +1,22 @@
+
+# set the include path for X, qt and KDE
+INCLUDES= $(all_includes)
+
+bin_PROGRAMS = kodo
+kodo_SOURCES = main.cpp kodometer.cpp kimagenumber.cpp
+METASOURCES = AUTO
+
+# the library search path.
+kodo_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+kodo_LDADD = $(LIB_KDEUI)
+
+messages:
+ $(XGETTEXT) $(kodo_SOURCES) -o $(podir)/kodo.pot
+
+KDE_ICON = kodo
+
+xdg_apps_DATA = kodo.desktop
+
+pics_DATA = numbers.png
+picsdir = $(kde_datadir)/kodo
+