summaryrefslogtreecommitdiffstats
path: root/kcalc/knumber/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kcalc/knumber/tests/CMakeLists.txt')
-rw-r--r--kcalc/knumber/tests/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/kcalc/knumber/tests/CMakeLists.txt b/kcalc/knumber/tests/CMakeLists.txt
new file mode 100644
index 0000000..ff3b6c5
--- /dev/null
+++ b/kcalc/knumber/tests/CMakeLists.txt
@@ -0,0 +1,36 @@
+#################################################
+#
+# (C) 2012 Golubev Alexander
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/kcalc/knumber
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${CMAKE_BINARY_DIR}/kcalc/knumber
+)
+
+
+##### knumbertest (test) ########################
+
+tde_add_executable( knumbertest AUTOMOC
+ SOURCES knumbertest.cpp
+ LINK knumber-static tdecore-shared
+)
+
+add_test( NAME knumbertest-test
+ COMMAND knumbertest)
+