summaryrefslogtreecommitdiffstats
path: root/khexedit/parts/kpart/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'khexedit/parts/kpart/CMakeLists.txt')
-rw-r--r--khexedit/parts/kpart/CMakeLists.txt46
1 files changed, 46 insertions, 0 deletions
diff --git a/khexedit/parts/kpart/CMakeLists.txt b/khexedit/parts/kpart/CMakeLists.txt
new file mode 100644
index 0000000..c89e1bf
--- /dev/null
+++ b/khexedit/parts/kpart/CMakeLists.txt
@@ -0,0 +1,46 @@
+#################################################
+#
+# (C) 2012 Golubev Alexander
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/khexedit/lib
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${CMAKE_SOURCE_DIR}/khexedit/lib
+)
+
+
+##### khexedit2part (kpart) #####################
+
+tde_add_kpart( khexedit2part AUTOMOC
+ SOURCES khepart.cpp khebrowserextension.cpp
+ khepartfactory.cpp
+ LINK khexeditcommon-shared kparts-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other data ################################
+
+install( FILES khexedit2part.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+)
+
+install( FILES khexedit2partui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/khexedit2part
+)
+