summaryrefslogtreecommitdiffstats
path: root/kmilo/thinkpad/kcmthinkpad/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kmilo/thinkpad/kcmthinkpad/CMakeLists.txt')
-rw-r--r--kmilo/thinkpad/kcmthinkpad/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/kmilo/thinkpad/kcmthinkpad/CMakeLists.txt b/kmilo/thinkpad/kcmthinkpad/CMakeLists.txt
new file mode 100644
index 0000000..0a79639
--- /dev/null
+++ b/kmilo/thinkpad/kcmthinkpad/CMakeLists.txt
@@ -0,0 +1,42 @@
+#################################################
+#
+# (C) 2012 Golubev Alexander
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+add_definitions(
+ -DKDE_BINDIR="${BIN_INSTALL_DIR}"
+)
+
+##### kcm_thinkpad (kpart) ######################
+
+tde_add_kpart( kcm_thinkpad AUTOMOC
+ SOURCES kcmthinkpad_general.ui main.cpp
+ LINK kio-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other data ################################
+
+install( FILES thinkpad.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)
+