summaryrefslogtreecommitdiffstats
path: root/ksim/monitors/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ksim/monitors/CMakeLists.txt')
-rw-r--r--ksim/monitors/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/ksim/monitors/CMakeLists.txt b/ksim/monitors/CMakeLists.txt
new file mode 100644
index 0000000..092112c
--- /dev/null
+++ b/ksim/monitors/CMakeLists.txt
@@ -0,0 +1,28 @@
+#################################################
+#
+# (C) 2012 Golubev Alexander
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( filesystem )
+add_subdirectory( net )
+add_subdirectory( cpu )
+add_subdirectory( disk )
+
+if( WITH_I8K )
+ add_subdirectory( i8k )
+endif( WITH_I8K )
+
+if( WITH_SNMP )
+ add_subdirectory( snmp )
+endif( WITH_SNMP )
+
+if( WITH_SENSORS )
+ add_subdirectory( lm_sensors )
+endif( WITH_SENSORS )
+