summaryrefslogtreecommitdiffstats
path: root/quanta/components/debugger/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'quanta/components/debugger/CMakeLists.txt')
-rw-r--r--quanta/components/debugger/CMakeLists.txt49
1 files changed, 49 insertions, 0 deletions
diff --git a/quanta/components/debugger/CMakeLists.txt b/quanta/components/debugger/CMakeLists.txt
new file mode 100644
index 00000000..6a9e7609
--- /dev/null
+++ b/quanta/components/debugger/CMakeLists.txt
@@ -0,0 +1,49 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( interfaces )
+add_subdirectory( gubed )
+add_subdirectory( dbgp )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/interfaces
+ ${CMAKE_SOURCE_DIR}/lib
+ ${CMAKE_SOURCE_DIR}/quanta/src
+ ${CMAKE_SOURCE_DIR}/quanta/project
+ ${CMAKE_SOURCE_DIR}/quanta/parsers
+ ${CMAKE_SOURCE_DIR}/quanta/utility
+ ${CMAKE_SOURCE_DIR}/quanta/messages
+ ${CMAKE_SOURCE_DIR}/quanta/parts/preview
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+
+##### debuggermanager (static) ##################
+
+tde_add_library( debuggermanager STATIC_PIC AUTOMOC
+ SOURCES
+ debuggermanager.cpp debuggerbreakpoint.cpp
+ quantadebuggerinterface.cpp debuggervariable.cpp
+ debuggerui.cpp variableslistview.cpp
+ debuggerbreakpointlist.cpp
+ debuggervariablesets.ui
+ debuggerbreakpointview.cpp
+ pathmapper.cpp pathmapperdialogs.ui
+ pathmapperdialog.cpp pathmapperdialog.h
+ conditionalbreakpointdialogs.ui
+ conditionalbreakpointdialog.cpp
+ conditionalbreakpointdialog.h
+ backtracelistview.cpp
+ LINK debuggerinterface-static
+)