summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-12-06 15:28:04 +0100
committerSlávek Banko <slavek.banko@axis.cz>2021-12-06 15:28:04 +0100
commit1382f3ddb7d28b59432c8c32455734bada2b6016 (patch)
tree78c3c8befc792d00a7957e4e6f8d71b5890aea66 /CMakeLists.txt
parenta69b55c674b0528c00598bea54b7a661f4e49f27 (diff)
downloadtqscintilla-1382f3ddb7d28b59432c8c32455734bada2b6016.tar.gz
tqscintilla-1382f3ddb7d28b59432c8c32455734bada2b6016.zip
cmake: Install the library to the default system location.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 00cb74c..2f882b4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -25,6 +25,7 @@ include( CheckIncludeFile )
include( CheckLibraryExists )
include( CheckCSourceCompiles )
include( CheckCXXSourceCompiles )
+include( GNUInstallDirs OPTIONAL )
#### include our cmake modules
@@ -35,6 +36,9 @@ include( TDEMacros )
##### setup install paths
+if( CMAKE_INSTALL_LIBDIR )
+ tde_setup_install_path( LIB_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}" )
+endif()
include( TDESetupPaths )
tde_setup_paths( )