summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 11:05:57 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-17 11:19:20 +0900
commit81d0f90b24db6d98545a5a78110aef400f9c8232 (patch)
treeb1cc295e40376ed2e41edc5992ce281fc173b18a /CMakeLists.txt
parentce4a1359711b176adbfe2867d87fb98a00ee68ec (diff)
downloadwlassistant-81d0f90b24db6d98545a5a78110aef400f9c8232.tar.gz
wlassistant-81d0f90b24db6d98545a5a78110aef400f9c8232.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2664c32..573780e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,7 +9,12 @@
#
#################################################
-cmake_minimum_required( VERSION 3.5 )
+
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
##### general package setup #####################
@@ -34,11 +39,6 @@ include( FindPkgConfig )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths #######################
include( TDESetupPaths )