summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-27 22:50:47 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-27 22:50:47 -0600
commit2c82d91b8c5ac4b7b5813a8c09b130e12180974c (patch)
tree751d78dee20fe34f785b0eccfbf82ddccae2648d /src/CMakeLists.txt
parenta805660cba37d573bd07615cbdb36d3bba11ecc1 (diff)
downloadabakus-2c82d91b8c5ac4b7b5813a8c09b130e12180974c.tar.gz
abakus-2c82d91b8c5ac4b7b5813a8c09b130e12180974c.zip
Fix FTBFS
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt14
1 files changed, 8 insertions, 6 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 36a4204..7fd1673 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -30,23 +30,25 @@ install( FILES abakusui.rc DESTINATION ${DATA_INSTALL_DIR} )
##### abakus (executable) #######################
-GENERATE_BISON_FLEX_SOURCES("lexer.ll", "", "parser.yy", "-d")
+GENERATE_BISON_FLEX_SOURCES(${CMAKE_SOURCE_DIR}/src/parser.yy "" ${CMAKE_SOURCE_DIR}/src/lexer.ll "")
if( HAVE_MPFR )
- set( MPFR_SOURCES "hmath.cpp number.c" )
+ set( MPFR_SOURCES "" )
set( MPFR_LIBRARIES "mpfr gmp" )
+else( HAVE_MPFR )
+ set( MPFR_SOURCES hmath.cpp number.c )
+ set( MPFR_LIBRARIES "" )
endif( HAVE_MPFR )
tde_add_executable( abakus AUTOMOC
SOURCES abakus.cpp abakuslistview.cpp
dragsupport.cpp editor.cpp
evaluator.cpp function.cpp
- lexer_lex.cpp mainwindow.cpp
- node.cpp numerictypes.cpp
- parser_yacc.cpp result.cpp
+ mainwindow.cpp node.cpp
+ numerictypes.cpp result.cpp
resultlistview.cpp resultlistviewtext.cpp
rpnmuncher.cpp valuemanager.cpp dcopIface.skel
- ${MPFR_SOURCES}
+ ${BF_SOURCES} ${MPFR_SOURCES}
LINK kio-shared tdecore-shared tdeprint-shared tdeui-shared DCOP-shared ${MPFR_LIBRARIES}
DESTINATION ${BIN_INSTALL_DIR}
)