summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-03-21 14:24:49 +0100
committerSlávek Banko <slavek.banko@axis.cz>2020-03-23 19:57:36 +0100
commita1a48db571e6fa1c3ae94a22546548b87e497dd2 (patch)
treec281a92c03893eec65f5aeddb4abdd66d20a4581 /src/CMakeLists.txt
parent47cb6069a5b60ae724903e31a5b5e19f797507b3 (diff)
downloadabakus-a1a48db571e6fa1c3ae94a22546548b87e497dd2.tar.gz
abakus-a1a48db571e6fa1c3ae94a22546548b87e497dd2.zip
Desktop file translations:
+ Creation of POT templates for desktop files added to CMakeL10n rules. + Added creation of translated desktop file during build. + The abakus.desktop will be installed to the XDG_APPS_INSTALL_DIR. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index a7365d2..be6ddd2 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -23,11 +23,14 @@ link_directories(
include( ${CMAKE_SOURCE_DIR}/BisonMacros.cmake )
+
##### other data ################################
-install( FILES abakus.desktop DESTINATION ${APPS_INSTALL_DIR}/Utilities )
+tde_create_translated_desktop( abakus.desktop )
+
install( FILES abakusui.rc DESTINATION ${DATA_INSTALL_DIR}/abakus )
+
##### abakus (executable) #######################
GENERATE_BISON_FLEX_SOURCES(${CMAKE_SOURCE_DIR}/src/parser.yy "" ${CMAKE_SOURCE_DIR}/src/lexer.ll "")