summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-01-29 12:40:35 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-01-29 12:40:35 +0100
commitb0c2717fd80109aa418e75298d66b6053fc6666e (patch)
tree0858b104af05b64a59e30e038f9ef2baf2dfb68e /CMakeLists.txt
parent74a23fb6b005000172652f4385decd8c730e933d (diff)
downloadakode-b0c2717fd80109aa418e75298d66b6053fc6666e.tar.gz
akode-b0c2717fd80109aa418e75298d66b6053fc6666e.zip
Update CMake rules
+ Add WITH_GCC_VISIBILITY option + Use common tde_setup_gcc_visibility + Add TestBigEndian and tde_setup_largefiles Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index df5b7ea..8819d46 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
#################################################
#
-# (C) 2015 Slávek Banko
+# (C) 2015-2019 Slávek Banko
# slavek (DOT) banko (AT) axis.cz
#
# Improvements and feedback are welcome
@@ -24,6 +24,7 @@ set( VERSION 2.0.2 )
include( FindPkgConfig )
include( CheckCXXSourceCompiles )
include( CheckFunctionExists )
+include( CheckSymbolExists )
include( CheckIncludeFile )
include( CheckLibraryExists )
@@ -32,7 +33,6 @@ include( CheckLibraryExists )
set( CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules" )
include( TDEMacros )
-tde_setup_architecture_flags( )
##### setup install paths #######################
@@ -45,6 +45,7 @@ tde_setup_paths( )
option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
OPTION( WITH_LIBLTDL "Build with libltdl" ${WITH_ALL_OPTIONS} )
OPTION( WITH_ALSA_SINK "Build with alsa sink" ${WITH_ALL_OPTIONS} )