summaryrefslogtreecommitdiffstats
path: root/qtmcop/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-05 00:01:18 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-05 00:01:18 +0000
commit42995d7bf396933ee60c5f89c354ea89cf13df0d (patch)
treecfdcea0ac57420e7baf570bfe435e107bb842541 /qtmcop/Makefile.am
downloadarts-42995d7b.tar.gz
arts-42995d7b.zip
Copy of aRts for Trinity modifications
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/dependencies/arts@1070145 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'qtmcop/Makefile.am')
-rw-r--r--qtmcop/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/qtmcop/Makefile.am b/qtmcop/Makefile.am
new file mode 100644
index 0000000..74f638a
--- /dev/null
+++ b/qtmcop/Makefile.am
@@ -0,0 +1,14 @@
+lib_LTLIBRARIES = libqtmcop.la
+
+INCLUDES = -I$(top_srcdir)/mcop -I$(top_builddir)/mcop $(all_includes) $(QT_INCLUDES)
+KDE_OPTIONS = qtonly
+
+libqtmcop_la_SOURCES = qiomanager.cc
+libqtmcop_la_LIBADD = $(top_builddir)/mcop/libmcop.la $(LIB_QT)
+libqtmcop_la_LDFLAGS = -no-undefined -version-info 1:0 $(KDE_RPATH) \
+ $(KDE_MT_LDFLAGS) $(QT_LDFLAGS) $(USER_LDFLAGS) $(X_LDFLAGS) $(LDFLAGS_AS_NEEDED)
+
+METASOURCES = qiomanager_p.moc
+
+artsincludedir = $(includedir)/arts
+artsinclude_HEADERS = qiomanager.h