summaryrefslogtreecommitdiffstats
path: root/soundserver/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2018-07-04 10:09:07 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2018-07-04 10:09:07 +0900
commitc1b7409de9bfd0c63c662b38b007d99dbb442d38 (patch)
treeb52a877bf351f698b982f34f539a733aab1bd040 /soundserver/CMakeLists.txt
parent5d9981995e34d44da2a1b236de4a7594fbe183a8 (diff)
downloadarts-c1b7409de9bfd0c63c662b38b007d99dbb442d38.tar.gz
arts-c1b7409de9bfd0c63c662b38b007d99dbb442d38.zip
cmake: Use set_property( SOURCE ... COMPILE_DEFINITIONS )
instead of set_source_files_properties( ... COMPILE_FLAGS ) to avoid the problem of double escaping quotation marks. Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'soundserver/CMakeLists.txt')
-rw-r--r--soundserver/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/soundserver/CMakeLists.txt b/soundserver/CMakeLists.txt
index 0f46bed..befa698 100644
--- a/soundserver/CMakeLists.txt
+++ b/soundserver/CMakeLists.txt
@@ -165,7 +165,7 @@ tde_add_executable( artswrapper
# FIXME "artsdpath" seems inconsistent name
# necessary for artswrapper
SET( artsdpath ${BIN_INSTALL_DIR}/artsd )
-set_target_properties( artswrapper PROPERTIES COMPILE_FLAGS -DEXECUTE=\\"${artsdpath}\\" )
+set_property( TARGET artswrapper APPEND PROPERTY COMPILE_DEFINITIONS EXECUTE="${artsdpath}" )
##### artsshell #################################