summaryrefslogtreecommitdiffstats
path: root/x11/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'x11/Makefile.am')
-rw-r--r--x11/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11/Makefile.am b/x11/Makefile.am
new file mode 100644
index 0000000..3a86768
--- /dev/null
+++ b/x11/Makefile.am
@@ -0,0 +1,29 @@
+if include_x11
+
+INCLUDES = -I$(top_srcdir)/mcop -I$(top_builddir)/mcop $(all_includes)
+
+lib_LTLIBRARIES = libx11globalcomm.la
+
+libx11globalcomm_la_SOURCES = x11globalcomm.cc x11globalcomm_impl.cc
+libx11globalcomm_la_LIBADD = $(top_builddir)/mcop/libmcop.la $(LIB_X11)
+libx11globalcomm_la_LDFLAGS = -no-undefined -module -version-info 1:0 $(X_LDFLAGS) $(all_libraries)
+
+DISTCLEANFILES = x11globalcomm.cc x11globalcomm.h \
+ x11globalcomm.mcoptype x11globalcomm.mcopclass
+
+x11globalcomm.cc x11globalcomm.h: $(srcdir)/x11globalcomm.idl $(MCOPIDL)
+ $(MCOPIDL) -t $(INCLUDES) $(srcdir)/x11globalcomm.idl
+
+x11globalcomm_impl.lo: x11globalcomm.h
+x11globalcomm.mcoptype: x11globalcomm.h
+x11globalcomm.mcopclass: x11globalcomm.h
+
+mcopclassdir = $(libdir)/mcop/Arts
+mcopclass_DATA = X11GlobalComm.mcopclass
+
+######## install idl typeinfo files
+
+mcoptypedir = $(libdir)/mcop
+mcoptype_DATA = x11globalcomm.mcoptype x11globalcomm.mcopclass
+
+endif