summaryrefslogtreecommitdiffstats
path: root/basket.spec
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-10 00:18:25 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-10 00:18:25 +0000
commitf21e5792b5084f5d008bf46f6316030c6dfb31e5 (patch)
treed51583b36aa1672bac78d98a682cdc330df27e4d /basket.spec
downloadbasket-f21e5792b5084f5d008bf46f6316030c6dfb31e5.tar.gz
basket-f21e5792b5084f5d008bf46f6316030c6dfb31e5.zip
Add author-abandoned basket application
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/basket@1072339 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'basket.spec')
-rw-r--r--basket.spec53
1 files changed, 53 insertions, 0 deletions
diff --git a/basket.spec b/basket.spec
new file mode 100644
index 0000000..36628af
--- /dev/null
+++ b/basket.spec
@@ -0,0 +1,53 @@
+%define name basket
+%define version 1.0.3.1
+%define release mantic0
+
+Summary: Taking care of your ideas.
+Name: %{name}
+Version: %{version}
+Release: %{release}
+License: GPL
+Vendor: slaout@linux62.org
+Url: http://basket.kde.org/
+Packager: packages@mantic.org
+Group: Utils
+Source: %{name}-%{version}.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}
+
+%description
+Taking care of your ideas.
+A note-taking application that makes it easy to write down ideas as you think, and quickly find them back later. Organizing your notes has never been so easy.
+
+%prep
+%setup
+if [ "`kde-config --prefix`" ]; then
+ CONFIGURE_PREFIX="`kde-config --prefix`"
+elif [ "${KDEDIR}" ]; then
+ CONFIGURE_PREFIX="${KDEDIR}"
+elif [ -d "/opt/kde" ]; then
+ CONFIGURE_PREFIX="/opt/kde"
+elif [ -d "/opt/kde3" ]; then
+ CONFIGURE_PREFIX="/opt/kde3"
+else
+ CONFIGURE_PREFIX="/usr"
+fi
+./configure --prefix="${CONFIGURE_PREFIX}" --enable-final
+
+%build
+%configure
+#%make
+
+%install
+make install DESTDIR=$RPM_BUILD_ROOT
+
+cd $RPM_BUILD_ROOT
+find . -type d | sed '1,2d;s,^\.,\%attr(-\,root\,root) \%dir ,' > /var/tmp/file.list.%{name}
+find . -type f | sed 's,^\.,\%attr(-\,root\,root) ,' >> /var/tmp/file.list.%{name}
+find . -type l | sed 's,^\.,\%attr(-\,root\,root) ,' >> /var/tmp/file.list.%{name}
+
+%clean
+rm -rf $RPM_BUILD_ROOT/*
+rm -rf $RPM_BUILD_DIR/%{name}-%{version}
+rm -rf /var/tmp/file.list.%{name}
+
+%files -f /var/tmp/file.list.%{name}