summaryrefslogtreecommitdiffstats
path: root/bibletime/frontend/mainindex/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2022-12-13 00:23:00 +0100
committerSlávek Banko <slavek.banko@axis.cz>2022-12-13 00:44:38 +0100
commitb02fdb4d705016a6c8e83f9d492b8df7c531b805 (patch)
tree766b40d911fbf23ef6c9ea8f41b4e523c7cf9503 /bibletime/frontend/mainindex/CMakeLists.txt
parentfacdbc2fcef5f9bfbd56c1eef53e61eb8e7438a1 (diff)
downloadbibletime-b02fdb4d705016a6c8e83f9d492b8df7c531b805.tar.gz
bibletime-b02fdb4d705016a6c8e83f9d492b8df7c531b805.zip
Conversion to CMake build system.
Remove the generated files from the source tree. Copy translations to a new directory layout. Added translation of .desktop files. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'bibletime/frontend/mainindex/CMakeLists.txt')
-rw-r--r--bibletime/frontend/mainindex/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/bibletime/frontend/mainindex/CMakeLists.txt b/bibletime/frontend/mainindex/CMakeLists.txt
new file mode 100644
index 0000000..2532e67
--- /dev/null
+++ b/bibletime/frontend/mainindex/CMakeLists.txt
@@ -0,0 +1,24 @@
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/${PROJECT_NAME}
+ ${CMAKE_SOURCE_DIR}/${PROJECT_NAME}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${CLUCENE_INCLUDE_DIRS}
+ ${SWORD_INCLUDE_DIRS}
+)
+
+
+##### mainindex (static)
+
+tde_add_library( mainindex STATIC-PIC AUTOMOC
+ SOURCES
+ cmainindex.cpp
+ cindexitem.cpp
+
+ LINK
+ searchdialog-static
+)