summaryrefslogtreecommitdiffstats
path: root/bibletime/frontend/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'bibletime/frontend/CMakeLists.txt')
-rw-r--r--bibletime/frontend/CMakeLists.txt47
1 files changed, 47 insertions, 0 deletions
diff --git a/bibletime/frontend/CMakeLists.txt b/bibletime/frontend/CMakeLists.txt
new file mode 100644
index 0000000..b7adf69
--- /dev/null
+++ b/bibletime/frontend/CMakeLists.txt
@@ -0,0 +1,47 @@
+
+add_subdirectory( util )
+add_subdirectory( searchdialog )
+add_subdirectory( mainindex )
+add_subdirectory( keychooser )
+add_subdirectory( displaywindow )
+add_subdirectory( display )
+
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/${PROJECT_NAME}
+ ${CMAKE_SOURCE_DIR}/${PROJECT_NAME}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${CLUCENE_INCLUDE_DIRS}
+ ${SWORD_INCLUDE_DIRS}
+)
+
+
+##### frontend (static)
+
+tde_add_library( frontend STATIC-PIC AUTOMOC
+ SOURCES
+ btinstallmgr.cpp
+ cbtconfig.cpp
+ cinputdialog.cpp
+ manageindicesform.ui
+ cmanageindiceswidget.cpp
+ coptionsdialog.cpp
+ cswordsetupdialog.cpp
+ cprofilemgr.cpp
+ cprofile.cpp
+ cprofilewindow.cpp
+ cexportmanager.cpp
+ cmdiarea.cpp
+ kstartuplogo.cpp
+ cdragdropmgr.cpp
+ cinfodisplay.cpp
+ cprinter.cpp
+ crossrefrendering.cpp
+ cswordsetupmodulelistview.cpp
+ cswordsetupinstallsourcesdialog.cpp
+ cmoduleindexdialog.cpp
+)