summaryrefslogtreecommitdiffstats
path: root/qt3/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'qt3/Makefile.am')
-rw-r--r--qt3/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/qt3/Makefile.am b/qt3/Makefile.am
new file mode 100644
index 0000000..0ffe90f
--- /dev/null
+++ b/qt3/Makefile.am
@@ -0,0 +1,37 @@
+if HAVE_QT3
+INCLUDES=-I$(top_srcdir) $(DBUS_CFLAGS) $(DBUS_CLIENT_CFLAGS) $(DBUS_QT3_CXXFLAGS)
+
+lib_LTLIBRARIES=libdbus-qt-1.la
+
+dbusinclude_HEADERS= \
+ dbus-qt.h message.h connection.h \
+ server.h
+
+dbusincludedir= $(includedir)/dbus-1.0/dbus/
+
+libdbus_qt_1_la_SOURCES = \
+ $(top_srcdir)/qt3/dbus-qthread.cpp \
+ $(top_srcdir)/qt3/message.cpp \
+ $(top_srcdir)/qt3/connection.cpp \
+ $(top_srcdir)/qt3/integrator.cpp \
+ $(top_srcdir)/qt3/server.cpp \
+ $(top_srcdir)/qt3/connection.h \
+ $(top_srcdir)/qt3/integrator.h \
+ $(top_srcdir)/qt3/server.h
+
+
+$(top_srcdir)/qt3/connection.cpp: connection.tqmoc
+$(top_srcdir)/qt3/integrator.cpp: integrator.tqmoc
+$(top_srcdir)/qt3/server.cpp: server.tqmoc
+$(top_srcdir)/qt3/connection.h: connection.tqmoc
+$(top_srcdir)/qt3/integrator.h: integrator.tqmoc
+$(top_srcdir)/qt3/server.h: server.tqmoc
+
+CLEANFILES=connection.tqmoc integrator.tqmoc server.tqmoc
+
+libdbus_qt_1_la_LIBADD= $(DBUS_LIBS) $(DBUS_QT3_LIBS)
+libdbus_qt_1_la_LDFLAGS= -version-info 1:0 -no-undefined
+
+%.tqmoc: %.h
+ $(QT3_TQMOC) $< > $@
+endif