summaryrefslogtreecommitdiffstats
path: root/data/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2022-12-13 17:48:14 +0100
committerSlávek Banko <slavek.banko@axis.cz>2022-12-13 17:59:43 +0100
commita6283453576ef8e387d837a13a1b4072a2b9532d (patch)
treed6c3c05037f58fbc65c6cfbff33e9c875e962b06 /data/CMakeLists.txt
parenta198c56607d4a2e3390e5583bf7eed19c7c9df0c (diff)
downloaddesktop-effects-tde-a6283453576ef8e387d837a13a1b4072a2b9532d.tar.gz
desktop-effects-tde-a6283453576ef8e387d837a13a1b4072a2b9532d.zip
Conversion to CMake build system.
Copy translations to a new directory layout. Added translation of .desktop files. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'data/CMakeLists.txt')
-rw-r--r--data/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
new file mode 100644
index 0000000..ca93643
--- /dev/null
+++ b/data/CMakeLists.txt
@@ -0,0 +1,10 @@
+
+##### other data
+
+file( GLOB data_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} * )
+list( REMOVE_ITEM data_files "CMakeLists.txt" )
+
+install(
+ FILES ${data_files}
+ DESTINATION ${DATA_INSTALL_DIR}/${PROJECT_NAME}
+)