summaryrefslogtreecommitdiffstats
path: root/debian/uncrustify-trinity/uncrustify-trinity-0.78.1/emscripten/README.md
diff options
context:
space:
mode:
Diffstat (limited to 'debian/uncrustify-trinity/uncrustify-trinity-0.78.1/emscripten/README.md')
-rw-r--r--debian/uncrustify-trinity/uncrustify-trinity-0.78.1/emscripten/README.md42
1 files changed, 42 insertions, 0 deletions
diff --git a/debian/uncrustify-trinity/uncrustify-trinity-0.78.1/emscripten/README.md b/debian/uncrustify-trinity/uncrustify-trinity-0.78.1/emscripten/README.md
new file mode 100644
index 00000000..22012383
--- /dev/null
+++ b/debian/uncrustify-trinity/uncrustify-trinity-0.78.1/emscripten/README.md
@@ -0,0 +1,42 @@
+building
+--------------------------------------------------------------------------------
+ **dependencies**: cmake, python, clang, emscripten, node
+
+ 1. create a `build` directory somewhere
+ 2. inside this directory call `cmake <CMakeLists.txt directory>` and `make`<br>
+ (the CMakeLists.txt file is located in <uncrustify_root_dir>/emscripten)
+
+Optionally the generated libUncrustify.js can be tested via `make emscripten_test`
+
+_libUncrustify.js_ example usage
+--------------------------------------------------------------------------------
+1. load module instance:
+ ```js
+ var uncrustify = libUncrustify();
+ ```
+
+2. set option settings either one at a time with:
+ ```js
+ uncrustify.set_option( "optionNameString", "newOptionValueString" );
+ ```
+
+ or a whole bunch via:
+
+ ```js
+ uncrustify.loadConfig( "configFileFormatString" )
+ ```
+
+3. set the language of the to be formated file string
+ ```js
+ uncrustify.set_language( languageInt );
+ ```
+
+4. format a file string:
+ ```js
+ var uncrustyFileString = uncrustify.uncrustify( "crustyFileString" );
+ ```
+
+5. delete initialized module instance:
+ ```js
+ uncrustify.destruct();
+ ```