summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
index 03be086..2ce6ef4 100644
--- a/po/CMakeLists.txt
+++ b/po/CMakeLists.txt
@@ -1,3 +1,9 @@
-# This file is genereted by trinity-automake-cmake-convert script by Fat-Zer
+# build translations if some are already available
-tde_auto_add_subdirectories( )
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} ${PROJECT_NAME}.po )
+
+foreach( _po ${po_files} )
+ string( REPLACE "/" ";" _path "${_po}" )
+ list( GET _path 0 _lang )
+ tde_create_translation( FILES ${_po} LANG ${_lang} )
+endforeach( )