summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt47
1 files changed, 47 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
new file mode 100644
index 0000000..94707cc
--- /dev/null
+++ b/tests/CMakeLists.txt
@@ -0,0 +1,47 @@
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/tdegtk
+ ${CMAKE_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${CAIRO_INCLUDE_DIRS}
+ ${GTK3_INCLUDE_DIRS}
+ ${PANGO_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+ ${CAIRO_LIBRARY_DIRS}
+ ${GTK3_LIBRARY_DIRS}
+ ${PANGO_LIBRARY_DIRS}
+)
+
+
+##### test-widgets (executable)
+
+tde_add_check_executable( test-widgets AUTOMOC
+
+ SOURCES
+ test-widgets.c
+
+ LINK
+ ${CAIRO_LIBRARIES}
+ ${GTK3_LIBRARIES}
+)
+
+
+##### test-painter (executable)
+
+tde_add_check_executable( test-painter AUTOMOC
+
+ SOURCES
+ test-painter.cpp
+
+ LINK
+ tqtcairo-shared
+ tdeui-shared
+ ${CAIRO_LIBRARIES}
+ ${GTK3_LIBRARIES}
+)