summaryrefslogtreecommitdiffstats
path: root/src/imageutils/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/imageutils/CMakeLists.txt')
-rw-r--r--src/imageutils/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/imageutils/CMakeLists.txt b/src/imageutils/CMakeLists.txt
new file mode 100644
index 0000000..9681a4a
--- /dev/null
+++ b/src/imageutils/CMakeLists.txt
@@ -0,0 +1,34 @@
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${EXIV2_INCLUDE_DIRS}
+ ${JPEG_INCLUDE_DIR}
+)
+
+
+##### gvimageutils (static)
+
+set( gvimageutils_SRCS imageutils.cpp jpegcontent.cpp scale.cpp transupp.c croppedqimage.cpp )
+
+if( HAVE_X86_MMX )
+ list( gvimageutils_SRCS APPEND _SRCS asm_scale.S )
+
+ # Force to use C compiler for asm_scale.S instead of ASM
+ # because it contains mixed code - ASM with C definitions
+ set_source_files_properties( asm_scale.S PROPERTIES LANGUAGE C )
+
+ add_compile_options( -DHAVE_X86_MMX )
+endif( )
+
+tde_add_library( gvimageutils STATIC_PIC AUTOMOC
+ SOURCES ${gvimageutils_SRCS}
+ LINK tdecore-shared tdeio-shared ${EXIV2_LIBRARIES} ${JPEG_LIBRARIES}
+)
+
+
+##### testjpegcontent (executable)
+
+tde_add_check_executable( testjpegcontent AUTOMOC
+ SOURCES testjpegcontent.cpp
+ LINK gvimageutils-static
+)