summaryrefslogtreecommitdiffstats
path: root/plugins/decoder/mp3/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2023-09-26 21:07:55 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2023-09-26 23:50:19 +0900
commit85f5856c5536c97abc0b524bc5ce3cb0b40bab2d (patch)
tree391f89ebadc495786b1de143378062d36199d62c /plugins/decoder/mp3/CMakeLists.txt
parent147aca7d8e7fe21364884200823577d0b9ade0a4 (diff)
downloadk3b-85f5856c5536c97abc0b524bc5ce3cb0b40bab2d.tar.gz
k3b-85f5856c5536c97abc0b524bc5ce3cb0b40bab2d.zip
Fix detection and linking of taglib
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'plugins/decoder/mp3/CMakeLists.txt')
-rw-r--r--plugins/decoder/mp3/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/plugins/decoder/mp3/CMakeLists.txt b/plugins/decoder/mp3/CMakeLists.txt
index 4b180f5..a04a4e9 100644
--- a/plugins/decoder/mp3/CMakeLists.txt
+++ b/plugins/decoder/mp3/CMakeLists.txt
@@ -18,11 +18,13 @@ include_directories(
${CMAKE_SOURCE_DIR}/libk3bdevice
${TDE_INCLUDE_DIR}
${TQT_INCLUDE_DIRS}
+ ${TAGLIB_INCLUDE_DIRS}
)
link_directories(
${TQT_LIBRARY_DIRS}
${MAD_LIBRARY_DIRS}
+ ${TAGLIB_LIBRARY_DIRS}
)
@@ -31,7 +33,7 @@ link_directories(
tde_add_kpart( libk3bmaddecoder AUTOMOC
SOURCES k3bmad.cpp k3bmaddecoder.cpp
LINK tdecore-shared k3b-shared k3bdevice-shared
- ${MAD_LIBRARIES}
+ ${MAD_LIBRARIES} ${TAGLIB_LIBRARIES}
DESTINATION ${PLUGIN_INSTALL_DIR}
)