summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2022-03-30 18:58:56 +0200
committerSlávek Banko <slavek.banko@axis.cz>2022-03-31 01:10:50 +0200
commita91c7c1df5f039a3611bf0aa320b15f70305e8b3 (patch)
treec9dc53a99ea050485e4130dbcebe2628cad939a8 /CMakeLists.txt
parent298fe4635696966d3cfcade2b8bce7fc908e4b84 (diff)
downloadkaffeine-a91c7c1df5f039a3611bf0aa320b15f70305e8b3.tar.gz
kaffeine-a91c7c1df5f039a3611bf0aa320b15f70305e8b3.zip
Change libdvdcss detection to search the default system directory for libraries.
This resolves issue TDE/tde-packaging#113. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 36f4c14..dc0744d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -33,6 +33,18 @@ set( CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules" )
include( TDEMacros )
+##### get the system's default path for libraries
+
+tde_save_and_set( CMAKE_INSTALL_PREFIX "/usr" )
+include( GNUInstallDirs OPTIONAL )
+if( CMAKE_INSTALL_LIBDIR )
+ set( SYSTEM_LIBDIR "${CMAKE_INSTALL_LIBDIR}" )
+else( )
+ set( SYSTEM_LIBDIR "lib${LIB_SUFFIX}" )
+endif( )
+tde_restore( CMAKE_INSTALL_PREFIX )
+
+
##### setup install paths
include( TDESetupPaths )