summaryrefslogtreecommitdiffstats
path: root/katapult/plugins/catalogs/amarokcatalog/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'katapult/plugins/catalogs/amarokcatalog/Makefile.am')
-rw-r--r--katapult/plugins/catalogs/amarokcatalog/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/katapult/plugins/catalogs/amarokcatalog/Makefile.am b/katapult/plugins/catalogs/amarokcatalog/Makefile.am
new file mode 100644
index 0000000..24de402
--- /dev/null
+++ b/katapult/plugins/catalogs/amarokcatalog/Makefile.am
@@ -0,0 +1,15 @@
+# set the include path for X, qt and KDE
+INCLUDES = -I$(top_srcdir)/katapult/common $(all_includes)
+
+# header files
+noinst_HEADERS = coverimage.h song.h amarokcatalog.h actionplaysong.h
+
+# use automoc
+METASOURCES = AUTO
+
+# our plugin
+kde_module_LTLIBRARIES = katapult_amarokcatalog.la
+katapult_amarokcatalog_la_SOURCES = settings.ui amarokcatalog.cpp coverimage.cpp song.cpp actionplaysong.cpp
+katapult_amarokcatalog_la_LDFLAGS = -module $(KDE_RPATH) $(KDE_PLUGIN) $(all_libraries)
+katapult_amarokcatalog_la_LIBADD = $(LIB_QT) $(LIB_KDECORE) -lDCOP $(LIB_KDEUI) $(LIB_KIO) $(top_builddir)/katapult/common/libkatapult.la
+kde_services_DATA = katapult_amarokcatalog.desktop