summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 11:14:31 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-17 17:12:02 +0900
commit710eecd8664c5e54d10238df414c40d9e26892f0 (patch)
treebaa897b3cb33867d536d33409f190c6d65e08402 /CMakeLists.txt
parentc62d6a21f065af251111a7071f203f5812263f8f (diff)
downloadkbarcode-710eecd8.tar.gz
kbarcode-710eecd8.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> (cherry picked from commit f26667e7054059e0abfa8524e68621d26fde3162)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 27f9496..50072a7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -32,11 +36,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )