summaryrefslogtreecommitdiffstats
path: root/translations/messages/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-30 22:12:53 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-30 22:12:53 +0200
commit682540075e11a775319b37bc443ad69ebec1b00b (patch)
tree181c4faa37ae9d73c7106530dd981e1dde26a615 /translations/messages/CMakeLists.txt
parent08f6bf65563cdf13f1f9d5fa813a4efc9788af97 (diff)
downloadkbarcode-682540075e11a775319b37bc443ad69ebec1b00b.tar.gz
kbarcode-682540075e11a775319b37bc443ad69ebec1b00b.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'translations/messages/CMakeLists.txt')
-rw-r--r--translations/messages/CMakeLists.txt14
1 files changed, 0 insertions, 14 deletions
diff --git a/translations/messages/CMakeLists.txt b/translations/messages/CMakeLists.txt
deleted file mode 100644
index 75c89f8..0000000
--- a/translations/messages/CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
-file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
-string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
-
-foreach( _po ${po_files} )
- get_filename_component( _lang ${_po} NAME_WE )
- if( "${_linguas}" MATCHES "^;*$" OR ";${_linguas};" MATCHES ";${_lang};" )
- if( "${_po}" MATCHES "^([^/]*)/.*" )
- string( REGEX REPLACE "^([^/]*)/.*" "\\1" _component "${_po}" )
- else( )
- set( _component "${PROJECT_NAME}" )
- endif( )
- tde_create_translation( FILES ${_po} LANG ${_lang} OUTPUT_NAME ${_component} )
- endif( )
-endforeach( )