summaryrefslogtreecommitdiffstats
path: root/kbarcode/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kbarcode/Makefile.am')
-rw-r--r--kbarcode/Makefile.am58
1 files changed, 58 insertions, 0 deletions
diff --git a/kbarcode/Makefile.am b/kbarcode/Makefile.am
new file mode 100644
index 0000000..665c3f2
--- /dev/null
+++ b/kbarcode/Makefile.am
@@ -0,0 +1,58 @@
+## Makefile.am for kbarcode
+
+# set the include path for X, qt and KDE
+INCLUDES = -I$(top_srcdir)/src $(all_includes)
+
+# these are the headers for your project
+
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+KDE_ICON = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kdedcoptest.pot
+
+# this is the program that gets installed. it's name is used for all
+# of the other Makefile.am variables
+bin_PROGRAMS = kbarcode
+
+# the application source, library search path, and link libraries
+
+kbarcode_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+kbarcode_LDADD = $(LIB_KABC) $(LIB_KSPELL) $(LIB_KDEPRINT) \
+ $(LIB_KDEUI) -lkjs -lpcre
+
+noinst_HEADERS = barcodecombo.h barcodedialog.h barcodedialogs.h \
+ commands.h configdialog.h confwizard.h csvimportdlg.h databasebrowser.h \
+ definition.h definitiondialog.h dsmainwindow.h dsrichtext.h kbarcode.h label.h \
+ labeleditor.h labelutils.h mimesources.h multilineeditdlg.h \
+ mycanvasitem.h mycanvasview.h mydatatable.h newlabel.h previewdialog.h \
+ printersettings.h printlabeldlg.h rectsettingsdlg.h smalldialogs.h sqltables.h \
+ tokenprovider.h xmlutils.h zplutils.h measurements.h editoriface.h kbarcodeiface.h \
+ batchiface.h kbarcodesettings.h batchprinter.h barcodeitem.h documentitem.h \
+ lineitem.h rectitem.h tcanvasitem.h textitem.h imageitem.h documentitemdlg.h \
+ propertywidget.h tec.h barcodeprinterdlg.h textlineitem.h textlineedit.h tokendialog.h \
+ barkode.h gnubarcode.h barkodeengine.h pixmapbarcode.h batchwizard.h csvfile.h \
+ referencecounted.h dstextedit.h encodingcombo.h purepostscript.h tbarcode2.h \
+ kactionmap.h
+
+kbarcode_SOURCES = barcodecombo.cpp barcodedialog.cpp \
+ barcodedialogs.cpp commands.cpp configdialog.cpp confwizard.cpp csvimportdlg.cpp \
+ databasebrowser.cpp definition.cpp definitiondialog.cpp dsmainwindow.cpp dsrichtext.cpp \
+ kbarcode.cpp label.cpp labeleditor.cpp labelutils.cpp main.cpp \
+ mimesources.cpp multilineeditdlg.cpp mycanvasitem.cpp mycanvasview.cpp mydatatable.cpp \
+ newlabel.cpp previewdialog.cpp printersettings.cpp printlabeldlg.cpp \
+ rectsettingsdlg.cpp smalldialogs.cpp sqltables.cpp tokenprovider.cpp xmlutils.cpp \
+ zplutils.cpp measurements.cpp editoriface.skel kbarcodeiface.skel batchiface.skel \
+ kbarcodesettings.cpp batchprinter.cpp barcodeitem.cpp documentitem.cpp lineitem.cpp \
+ rectitem.cpp tcanvasitem.cpp textitem.cpp imageitem.cpp documentitemdlg.cpp \
+ propertywidget.cpp tec.cpp barcodeprinterdlg.cpp textlineitem.cpp textlineedit.cpp \
+ tokendialog.cpp barkode.cpp gnubarcode.cpp barkodeengine.cpp pixmapbarcode.cpp batchwizard.cpp \
+ csvfile.cpp referencecounted.cpp dstextedit.cpp encodingcombo.cpp purepostscript.cpp tbarcode2.cpp \
+ kactionmap.cpp
+
+xdg_apps_DATA = kbarcode.desktop kbarcode-batch.desktop kbarcode-editor.desktop kbarcode-label.desktop kbarcode-single.desktop
+
+datafiles_DATA = logo.png barcodes.html exampledata.sql labeldefinitions.sql barcode.ps rules.xml
+datafilesdir = $(kde_datadir)/kbarcode