summaryrefslogtreecommitdiffstats
path: root/kbfx-0.4.9.3.1.ebuild
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-02-17 00:43:50 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-02-17 00:43:50 +0000
commitceea23677c61f20759ae986bd77b0d5c4d673edb (patch)
tree3fcec1702eaf9c14d1dd736e594f5df08dab4001 /kbfx-0.4.9.3.1.ebuild
downloadkbfx-ceea23677c61f20759ae986bd77b0d5c4d673edb.tar.gz
kbfx-ceea23677c61f20759ae986bd77b0d5c4d673edb.zip
Added old KDE3 version of kbfx
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/kbfx@1091549 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kbfx-0.4.9.3.1.ebuild')
-rw-r--r--kbfx-0.4.9.3.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/kbfx-0.4.9.3.1.ebuild b/kbfx-0.4.9.3.1.ebuild
new file mode 100644
index 0000000..f8dbb73
--- /dev/null
+++ b/kbfx-0.4.9.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header
+
+inherit kde eutils
+need-kde 3.3
+
+MY_PN="${PN}-0.4.9.3.1"
+S="${WORKDIR}/${MY_PN}"
+
+DESCRIPTION="KDE alternative K-Menu"
+HOMEPAGE="http://www.kbfx.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc ~amd64"
+IUSE="strigi"
+
+DEPEND=">=dev-util/cmake-2.4.2
+ strigi? ( kde-misc/strigi )"
+
+export DESTDIR=${D}
+
+src_compile() {
+ cd ${S}
+ cmake \
+ -DCMAKE_INSTALL_PREFIX:PATH=${KDEDIR} \
+ -DUSE_STRIGI:BOOL=$( use strigi && echo ON || echo OFF ) \
+ . || die
+}