summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-04-05 15:45:12 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-04-05 15:45:12 +0200
commit976023e1c3762587023803e86a8c184da3e67915 (patch)
tree501906ec89f6bacc6e876da9a18f26909c34ccc8 /src/CMakeLists.txt
parent9cc21b83f7b637450c4fc40d033ccad7896b07f1 (diff)
downloadkbibtex-976023e1c3762587023803e86a8c184da3e67915.tar.gz
kbibtex-976023e1c3762587023803e86a8c184da3e67915.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index bf18877..d4cc44d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -113,14 +113,16 @@ install(
DESTINATION ${DATA_INSTALL_DIR}/${PROJECT_NAME}
)
-install(
- FILES kbibtex_part.desktop
+tde_create_translated_desktop(
+ SOURCE kbibtex_part.desktop
DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files
)
-install(
- FILES ${PROJECT_NAME}.desktop
+tde_create_translated_desktop(
+ SOURCE ${PROJECT_NAME}.desktop
DESTINATION ${XDG_APPS_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files
)
install(