summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-01-13 15:27:30 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-01-13 15:27:30 +0100
commitb1833cf50dace47a755e575b1faa5372b7fb7d1a (patch)
tree1f2327b8e10f7277922d143e488ec405264ebaba /CMakeLists.txt
parentcf3bddf185cee68613aebfa784597de29f57257c (diff)
downloadkbookreader-b1833cf50dace47a755e575b1faa5372b7fb7d1a.tar.gz
kbookreader-b1833cf50dace47a755e575b1faa5372b7fb7d1a.zip
Added controlled conversions to char* instead of automatic ascii conversions.
The definition of -UTQT_NO_ASCII_CAST is no longer needed. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bf31ff6..7c70150 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,7 +58,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings
-add_definitions( -DHAVE_CONFIG_H -UTQT_NO_ASCII_CAST )
+add_definitions( -DHAVE_CONFIG_H )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )