summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt75
1 files changed, 75 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..5224cac
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,75 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### bookreader (executable)
+
+tde_add_executable( bookreader AUTOMOC
+
+ SOURCES
+ settingsdlg.ui
+ main.cpp
+ bookreader.cpp
+ bookreaderiface.skel
+ bookwidget.cpp
+ theme.cpp
+ settings.kcfgc
+ renderer.cpp
+ bookmark.cpp
+ bookmarksdlg.cpp
+ LINK
+ tdecore-shared
+ tdeui-shared
+ tdeio-shared
+ tdeprint-shared
+
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### bookreader_client (executable)
+
+tde_add_executable( bookreader_client AUTOMOC
+
+ SOURCES
+ bookreader_client.cpp
+ LINK
+ tdecore-shared
+ tdeui-shared
+ tdeio-shared
+
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### icons
+
+tde_install_icons( )
+
+
+##### other data
+
+install(
+ FILES bookreaderui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/bookreader
+)
+
+install(
+ FILES bookreader.desktop
+ DESTINATION ${APPS_INSTALL_DIR}/Office
+)
+
+install(
+ FILES bookreader.kcfg
+ DESTINATION ${KCFG_INSTALL_DIR}
+)