summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9fa1392..95460ed 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -72,8 +72,14 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
add_subdirectory( lib )
add_subdirectory( src )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+
+
+##### other data ################################
+
+if( WITH_TDE )
+ tde_conditional_add_project_docs( BUILD_DOC )
+ tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
+endif()
##### write configure files