summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-05-31 01:31:04 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-05-31 01:31:04 -0500
commit47aae9120db93e3120a35ce145ae7b7358890ae4 (patch)
treefae83f6474ecb71bada1833afd016435f211d903 /src/Makefile.am
downloadkcmldapcontroller-47aae9120db93e3120a35ce145ae7b7358890ae4.tar.gz
kcmldapcontroller-47aae9120db93e3120a35ce145ae7b7358890ae4.zip
Initial import of skeleton for development
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..e78843e
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,19 @@
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+# Install this plugin in the KDE modules directory
+kde_module_LTLIBRARIES = kcm_ldapcontroller.la
+
+kcm_ldapcontroller_la_SOURCES = ldapcontroller.cpp ldapcontrollerconfigbase.ui
+kcm_ldapcontroller_la_LIBADD = -lkio $(LIB_TDEUI)
+kcm_ldapcontroller_la_LDFLAGS = -avoid-version -module -no-undefined \
+ $(all_libraries)
+
+
+xdg_apps_DATA = ldapcontroller.desktop
+
+
+messages: rc.cpp
+ $(EXTRACTRC) `find -name \*.ui -o -name \*.rc` > rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kcmldapcontroller.pot
+