summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2018-12-13 18:49:14 +0100
committerSlávek Banko <slavek.banko@axis.cz>2018-12-13 18:49:14 +0100
commit90d92cc7061207746e333f5d45f2875e2b538375 (patch)
treee797be0b5e8f6e2ba3a1cbfe6814b9d994fe4a25 /CMakeLists.txt
parent0557917aa98c792eb316ce176c97849f3e7bdb3e (diff)
downloadkcpuload-90d92cc7061207746e333f5d45f2875e2b538375.tar.gz
kcpuload-90d92cc7061207746e333f5d45f2875e2b538375.zip
Add CMakeL10n rules.
Create translation template. Add CMake rules to build translations. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6c9f7bf..be40fa2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,6 +47,7 @@ option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden"
option( BUILD_ALL "Build all" ON )
option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
##### configure checks
@@ -68,6 +69,7 @@ set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
add_subdirectory( src )
add_subdirectory( icons )
tde_conditional_add_subdirectory( BUILD_DOC doc )
+tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
##### write configure files