summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <g-gregory@gmx.fr>2019-06-06 15:18:55 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-03-14 17:33:50 +0100
commit0ec802b1628ffdac91ec87714bf5aaf769ce213e (patch)
tree578cba3444795a7c34361dee931784a98938ec83 /po/CMakeLists.txt
parentc29622eb02355fba3aefb92895b257cd0454a5ca (diff)
downloadkdbg-0ec802b1.tar.gz
kdbg-0ec802b1.zip
conversion to the cmake building system.
Signed-off-by: gregory guy <gregory-tde@laposte.net> (cherry picked from commit 49c43d74d820cae7ce5a7291702bbc5ae1b3bf9e)
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
new file mode 100644
index 0000000..75c89f8
--- /dev/null
+++ b/po/CMakeLists.txt
@@ -0,0 +1,14 @@
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
+string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
+
+foreach( _po ${po_files} )
+ get_filename_component( _lang ${_po} NAME_WE )
+ if( "${_linguas}" MATCHES "^;*$" OR ";${_linguas};" MATCHES ";${_lang};" )
+ if( "${_po}" MATCHES "^([^/]*)/.*" )
+ string( REGEX REPLACE "^([^/]*)/.*" "\\1" _component "${_po}" )
+ else( )
+ set( _component "${PROJECT_NAME}" )
+ endif( )
+ tde_create_translation( FILES ${_po} LANG ${_lang} OUTPUT_NAME ${_component} )
+ endif( )
+endforeach( )