summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in241
1 files changed, 0 insertions, 241 deletions
diff --git a/configure.in b/configure.in
deleted file mode 100644
index b453ada..0000000
--- a/configure.in
+++ /dev/null
@@ -1,241 +0,0 @@
-dnl =======================================================
-dnl FILE: ./admin/configure.in.min
-dnl =======================================================
-
-dnl This file is part of the KDE libraries/packages
-dnl Copyright (C) 2001 Stephan Kulow (coolo@kde.org)
-
-dnl This file is free software; you can redistribute it and/or
-dnl modify it under the terms of the GNU Library General Public
-dnl License as published by the Free Software Foundation; either
-dnl version 2 of the License, or (at your option) any later version.
-
-dnl This library is distributed in the hope that it will be useful,
-dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
-dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-dnl Library General Public License for more details.
-
-dnl You should have received a copy of the GNU Library General Public License
-dnl along with this library; see the file COPYING.LIB. If not, write to
-dnl the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
-dnl Boston, MA 02110-1301, USA.
-
-# Original Author was Kalle@kde.org
-# I lifted it in some mater. (Stephan Kulow)
-# I used much code from Janos Farkas
-
-dnl Process this file with autoconf to produce a configure script.
-
-AC_INIT(acinclude.m4) dnl a source file from your sub dir
-
-dnl This is so we can use kde-common
-AC_CONFIG_AUX_DIR(admin)
-
-dnl This ksh/zsh feature conflicts with `cd blah ; pwd`
-unset CDPATH
-
-dnl Checking host/target/build systems, for make, install etc.
-AC_CANONICAL_SYSTEM
-dnl Perform program name transformation
-AC_ARG_PROGRAM
-
-dnl Automake doc recommends to do this only here. (Janos)
-AM_INIT_AUTOMAKE(kdbg, 2.2.2) dnl searches for some needed programs
-
-KDE_SET_PREFIX
-
-dnl generate the config header
-AM_CONFIG_HEADER(config.h) dnl at the distribution this done
-
-dnl Checks for programs.
-AC_CHECK_COMPILERS
-AC_ENABLE_SHARED(yes)
-AC_ENABLE_STATIC(no)
-KDE_PROG_LIBTOOL
-
-dnl for NLS support. Call them in this order!
-dnl WITH_NLS is for the po files
-AM_KDE_WITH_NLS
-
-dnl KDE_USE_QT
-AC_PATH_KDE
-dnl =======================================================
-dnl FILE: configure.in.in
-dnl =======================================================
-
-#MIN_CONFIG
-
-dnl PACKAGE set before
-
-KDE_CREATE_SUBDIRSLIST
-AC_CONFIG_FILES([ Makefile ])
-AC_CONFIG_FILES([ kdbg/Makefile ])
-AC_CONFIG_FILES([ kdbg/doc/Makefile ])
-AC_CONFIG_FILES([ kdbg/doc/de/Makefile ])
-AC_CONFIG_FILES([ kdbg/doc/en/Makefile ])
-AC_CONFIG_FILES([ kdbg/doc/ru/Makefile ])
-AC_CONFIG_FILES([ kdbg/pics/Makefile ])
-AC_CONFIG_FILES([ kdbg/testprogs/Makefile ])
-AC_CONFIG_FILES([ kdbg/typetables/Makefile ])
-AC_CONFIG_FILES([ po/Makefile ])
-dnl Checks for header files.
-AC_LANG_C dnl switch to C
-AC_HEADER_DIRENT dnl check for dirent.h
-AC_HEADER_STDC dnl check for other stdc headers. More traditional ;)
-dnl check for some more header files. You can remove some of
-dnl them, if you want to. But it doesn't hurt
-AC_CHECK_HEADERS(fcntl.h sys/time.h unistd.h sys/cdefs.h)
-AC_CHECK_HEADERS(fnmatch.h sysent.h strings.h sys/stat.h)
-AC_CHECK_HEADERS(sys/ioctl.h pty.h libutil.h util.h)
-
-dnl Checks for libraries.
-AC_CHECK_LIB(socket, socket, [LIBSOCKET="-lsocket -lnsl"]) dnl for Solaris' X11
-AC_SUBST(LIBSOCKET)
-
-dnl Checks for typedefs, structures, and compiler characteristics.
-AC_HEADER_TIME
-
-dnl Checks for library functions.
-AC_CHECK_FUNCS(setpgid putenv socket vsnprintf mkfifo)
-
-dnl pseudo tty support in glibc2
-AC_SEARCH_LIBS(openpty, util,
- AC_DEFINE_UNQUOTED(HAVE_FUNC_OPENPTY, 1, [Define if you have openpty]))
-
-dnl Check whether we want much debugging output
-AH_TEMPLATE([WANT_TRACE_OUTPUT],
- [Define if you want to see voluminous trace output])
-AC_MSG_CHECKING([whether kdbg should generate lots of trace output])
-dnl Default is no trace output
-AC_ARG_ENABLE(lots-a-trace,
- [ --enable-lots-a-trace generate lots of trace output [default=no]],
- WANT_TRACE_OUTPUT=$enableval, WANT_TRACE_OUTPUT=no)
-AC_MSG_RESULT($WANT_TRACE_OUTPUT)
-if test "x$WANT_TRACE_OUTPUT" = "xyes"; then
- AC_DEFINE_UNQUOTED(WANT_TRACE_OUTPUT)
-fi
-
-dnl Check whether test programs should be compiled
-dnl Default is not to compile them
-AC_ARG_ENABLE(testprogs,
- [ --enable-testprogs compile test programs [default=no]],
- [buildtestprogs=$enableval],[buildtestprogs=no])
-AM_CONDITIONAL(BUILDTESTPROGS,test "x$buildtestprogs" = "xyes")
-dnl write a notice into the log
-echo "build test programs: $buildtestprogs" >&5
-
-dnl Check where the communication with gdb should be logged
-AC_MSG_CHECKING([where communication with gdb should be logged])
-dnl Default is ./gdb-transcript until kdbg is released
-AC_ARG_WITH(transcript,
- [ --with-transcript=file log communication with gdb [default=not logged]],
- GDB_TRANSCRIPT=$withval, GDB_TRANSCRIPT=no)
-if test "x$GDB_TRANSCRIPT" = "xyes"; then
- GDB_TRANSCRIPT="./gdb-transcript"
-fi
-if test "x$GDB_TRANSCRIPT" = "xno"; then
- GDB_TRANSCRIPT="not logged"
-else
- dnl add quotes
- GDB_TRANSCRIPT=\"$GDB_TRANSCRIPT\"
- AC_DEFINE_UNQUOTED(GDB_TRANSCRIPT, $GDB_TRANSCRIPT,
- [Define to the name of the file that communication with gdb
- should be logged to; undefine it for no logging])
-fi
-AC_MSG_RESULT($GDB_TRANSCRIPT)
-
-dnl Check whether placement new works
-AH_TEMPLATE([HAVE_PLACEMENT_NEW],[Define if placement new works])
-AC_LANG_CPLUSPLUS
-AC_MSG_CHECKING(whether placement new is available)
-AC_CACHE_VAL(ac_cv_have_placement_new,
-[
-AC_TRY_COMPILE([
-#include <new>
-],
-[
-int ii;
-new(&ii) int;
-],
-ac_cv_have_placement_new=yes,
-ac_cv_have_placement_new=no)
-])
-AC_MSG_RESULT($ac_cv_have_placement_new)
-if eval "test \"`echo `$ac_cv_have_placement_new\" = yes"; then
- AC_DEFINE(HAVE_PLACEMENT_NEW)
-fi
-
-dnl -----------------
-AC_PATH_PROG(PS_COMMAND, ps)
-if test -n "$PS_COMMAND"; then
- AC_MSG_CHECKING(for suitable ps invocation)
-
- PS_COMMAND="$PS_COMMAND -eo pid,ppid,uid,vsz,etime,time,args"
- if $PS_COMMAND > /dev/null 2>&1; then
- # works in principle; check output: extract first line, but avoid 'head -1'
- set x `$PS_COMMAND | (read firstline; echo "$firstline")`
- if test "$*" = "x PID PPID UID VSZ ELAPSED TIME COMMAND"; then
- : # fine
- else
- PS_COMMAND="" # not suitable
- fi
- else
- PS_COMMAND="" # not suitable
- fi
-
- if test -n "$PS_COMMAND"; then
- AC_MSG_RESULT($PS_COMMAND)
- PS_COMMAND=\"`echo $PS_COMMAND | sed -e 's/ /", "/g'`\"
- AC_DEFINE_UNQUOTED(PS_COMMAND, $PS_COMMAND,
- [Define how to invoke ps])
- else
- AC_MSG_RESULT([not suitable])
- fi
-fi
-AM_CONDITIONAL(HAVE_PS_COMMAND, test -n "$PS_COMMAND")
-AC_OUTPUT
-# Check if KDE_SET_PREFIX was called, and --prefix was passed to configure
-if test -n "$kde_libs_prefix" -a -n "$given_prefix"; then
- # And if so, warn when they don't match
- if test "$kde_libs_prefix" != "$given_prefix"; then
- # And if kde doesn't know about the prefix yet
- echo ":"`tde-config --path exe`":" | grep ":$given_prefix/bin/:" 2>&1 >/dev/null
- if test $? -ne 0; then
- echo ""
- echo "Warning: you chose to install this package in $given_prefix,"
- echo "but KDE was found in $kde_libs_prefix."
- echo "For this to work, you will need to tell KDE about the new prefix, by ensuring"
- echo "that TDEDIRS contains it, e.g. export TDEDIRS=$given_prefix:$kde_libs_prefix"
- echo "Then restart KDE."
- echo ""
- fi
- fi
-fi
-
-if test x$GXX = "xyes" -a x$kde_have_gcc_visibility = "xyes" -a x$kde_cv_val_qt_gcc_visibility_patched = "xno"; then
- echo ""
- echo "Your GCC supports symbol visibility, but the patch for Qt supporting visibility"
- echo "was not included. Therefore, GCC symbol visibility support remains disabled."
- echo ""
- echo "For better performance, consider including the Qt visibility supporting patch"
- echo "located at:"
- echo ""
- echo "http://bugs.kde.org/show_bug.cgi?id=109386"
- echo ""
- echo "and recompile all of Qt and KDE. Note, this is entirely optional and"
- echo "everything will continue to work just fine without it."
- echo ""
-fi
-
-if test "$all_tests" = "bad"; then
- if test ! "$cache_file" = "/dev/null"; then
- echo ""
- echo "Please remove the file $cache_file after changing your setup"
- echo "so that configure will find the changes next time."
- echo ""
- fi
-else
- echo ""
- echo "Good - your configure finished. Start make now"
- echo ""
-fi