summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 10:52:11 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-17 15:41:38 +0900
commitdf4776754baf1c0e745423cfdb32ee938f33027c (patch)
tree7f6a78a251d6d8d80716c16a4eb2a43d3e6f7448 /CMakeLists.txt
parenta809161606f1072987c9b4acaf943e0de82fe624 (diff)
downloadkdiff3-df477675.tar.gz
kdiff3-df477675.zip
Use centralized cmake versionr14.1.2
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> (cherry picked from commit 5078bedfdce40325ca513ed3f98da022e856e50c)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9c2b8fa..7558622 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -31,11 +35,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )