summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-30 22:40:16 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-30 22:40:16 +0200
commitcfde71551f0c3e754bbff27ea6722fa479fdfdbe (patch)
treea97c16388c8912a00bc8643f2e7597ada6d61f44 /CMakeLists.txt
parentcc0e8f9c505ce7dcedd35cbca7e9a617400efc8f (diff)
downloadkdirstat-cfde71551f0c3e754bbff27ea6722fa479fdfdbe.tar.gz
kdirstat-cfde71551f0c3e754bbff27ea6722fa479fdfdbe.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 82397ee..5623d7d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,10 +69,13 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( ${PROJECT_NAME} )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
+
##### write configure files