summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..6c7afac
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,48 @@
+# Toplevel Makefile.am for KDirStat
+#
+# Originally generated by KDevelop, modified by sh@suse.de
+#
+
+SUBDIRS = kdirstat po doc
+
+EXTRA_DIST = \
+ AUTHORS \
+ COPYING \
+ COPYING.LIB \
+ CREDITS \
+ ChangeLog \
+ INSTALL \
+ README \
+ TODO \
+ admin \
+ build-howto.html \
+ kdirstat.kdevprj \
+ kdirstat.lsm
+
+
+# This is not a GNU package. You can remove this line
+# if have all needed files a GNU package needs.
+AUTOMAKE_OPTIONS = foreign
+
+CLEANFILES = $(wildcard autom4te.cache/*)
+
+$(top_srcdir)/configure.in: configure.in.in $(top_srcdir)/subdirs
+ cd $(top_srcdir) && $(MAKE) -f admin/Makefile.common configure.in ;
+
+$(top_srcdir)/subdirs:
+ cd $(top_srcdir) && $(MAKE) -f admin/Makefile.common subdirs
+
+$(top_srcdir)/acinclude.m4: $(top_srcdir)/admin/acinclude.m4.in $(top_srcdir)/admin/libtool.m4.in
+ @cd $(top_srcdir) && cat admin/acinclude.m4.in admin/libtool.m4.in > acinclude.m4
+
+MAINTAINERCLEANFILES = subdirs configure.in acinclude.m4 configure.files
+
+package-messages:
+ $(MAKE) -f admin/Makefile.common package-messages
+ $(MAKE) -C po merge
+
+
+dist-hook:
+ cd $(top_distdir) && perl admin/am_edit -padmin
+ cd $(top_distdir) && $(MAKE) -f admin/Makefile.common subdirs
+