summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-07-23 13:59:29 +0200
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-07-24 11:48:46 +0900
commitbc0e1a135a3d2f518a79f5c9117ea61c2ee34468 (patch)
treebf387d2423801368c332edfffe161e73451459ce /CMakeLists.txt
parent8b0b12ec3264293b72e3f5166a6cbad889e96a7c (diff)
downloadkdpkg-bc0e1a135a3d2f518a79f5c9117ea61c2ee34468.tar.gz
kdpkg-bc0e1a135a3d2f518a79f5c9117ea61c2ee34468.zip
Drop automake build support.
Add basic cmake build instructions. Remove empty files ChangeLog, TODO and NEWS. Rework of the README file. Some cosmetics. Signed-off-by: gregory guy <gregory-tde@laposte.net> (cherry picked from commit d6ae994c10d1d3e9df01d352f95ac825e51c01e2)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 90208c8..1d2eef5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,15 +41,15 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
##### user requested modules
-option( BUILD_ALL "Build all" ON )
-option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
-option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+option( BUILD_ALL "Build all" ON )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
##### configure checks
@@ -69,9 +69,9 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( icon )
-add_subdirectory( ${PROJECT_NAME} )
+add_subdirectory( ${PROJECT_NAME} )
add_subdirectory( ${PROJECT_NAME}-install )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )