summaryrefslogtreecommitdiffstats
path: root/kipi-plugins/imageviewer/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kipi-plugins/imageviewer/Makefile.am')
-rw-r--r--kipi-plugins/imageviewer/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/kipi-plugins/imageviewer/Makefile.am b/kipi-plugins/imageviewer/Makefile.am
new file mode 100644
index 0000000..628c44f
--- /dev/null
+++ b/kipi-plugins/imageviewer/Makefile.am
@@ -0,0 +1,25 @@
+# set the include path for X, qt and KDE
+INCLUDES = $(KIPI_PLUGINS_COMMON_INCLUDE) $(LIBKIPI_CFLAGS) $(LIBKDCRAW_CFLAGS) $(all_includes)
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+# Install this plugin in the KDE modules directory
+kde_module_LTLIBRARIES = kipiplugin_viewer.la
+
+kipiplugin_viewer_la_DEPENDENCIES = $(LIBKIPI_LIBS_DEP) $(LIBKDCRAW_LIBS_DEP)
+kipiplugin_viewer_la_SOURCES = viewerwidget.cpp texture.cpp timer.cpp plugin_viewer.cpp help.ui
+kipiplugin_viewer_la_LIBADD = $(LIBKIPI_LIBS) $(LIBKDCRAW_LIBS) $(LIB_KIO) $(LIB_KDEUI) $(LIB_KDECORE) $(LIB_QT) -lGL
+kipiplugin_viewer_la_LDFLAGS = $(KIPI_PLUGINS_COMMON_LDFLAGS) -module $(KDE_PLUGIN) $(all_libraries)
+
+kde_services_DATA = kipiplugin_viewer.desktop
+
+
+kipiviewericondir = $(kde_datadir)/kipiplugin_viewer/icons
+kipiviewericon_ICON = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/kipiplugin_viewer.pot
+
+
+#icon is still missing \ No newline at end of file