summaryrefslogtreecommitdiffstats
path: root/kipi-plugins/wallpaper/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kipi-plugins/wallpaper/Makefile.am')
-rw-r--r--kipi-plugins/wallpaper/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/kipi-plugins/wallpaper/Makefile.am b/kipi-plugins/wallpaper/Makefile.am
new file mode 100644
index 0000000..8d980d0
--- /dev/null
+++ b/kipi-plugins/wallpaper/Makefile.am
@@ -0,0 +1,18 @@
+INCLUDES = $(LIBKIPI_CFLAGS) $(all_includes)
+METASOURCES = AUTO
+
+kde_module_LTLIBRARIES = kipiplugin_wallpaper.la
+kipiplugin_wallpaper_la_DEPENDENCIES = $(LIBKIPI_LIBS_DEP)
+kipiplugin_wallpaper_la_SOURCES = plugin_wallpaper.cpp
+
+kipiplugin_wallpaper_la_LIBADD = $(LIBKIPI_LIBS) $(LIB_KIO) $(LIB_KDEUI) $(LIB_KDECORE) $(LIB_QT)
+
+kipiplugin_wallpaper_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+
+pluginsdir = $(kde_datadir)/kipi/plugins
+
+kde_services_DATA = kipiplugin_wallpaper.desktop
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/kipiplugin_wallpaper.pot
+